首页 > 编程学习记录 > 易语言传送支持库:提示“无法获得文件大小”

201612月20

易语言传送支持库:提示“无法获得文件大小”

作者:admin 0 Comments 发表评论

明明是按照教程来写的代码,但是提示“无法获得文件大小”,然后就没有然后了,直接停止了下载。测试发现如果是下载MP3、exe等的链接没有问题,但是下载HTML文件时有问题,下面是截图和代码:

提示:无法获取文件大小

http://pan.baidu.com/s/1bpgOQQV

如果不愿意下载,可以直接复制下面的:

.版本 2
.支持库 downlib
.支持库 spec

.程序集 窗口程序集_启动窗口
.程序集变量 下载对象, 下载对象
.程序集变量 配置信息, 任务参数

.子程序 _按钮1_被单击

配置信息.类型 = #传送常量.下载

配置信息.文件地址 = “http://im.qq.com/”
配置信息.本地文件路径 = “F:\99.html”
配置信息.默认线程数 = 1
配置信息.连接超时 = 20000
配置信息.发送超时 = 20000
配置信息.接收超时 = 20000
配置信息.下载速度 = 0

配置信息.日志回调函数 = &日志回调函数子程序 ‘ 测试可以不用
配置信息.交互回调函数 = &交互回调函数子程序 ‘ 必须要有
下载对象.增加新任务 (配置信息)
.子程序 日志回调函数子程序
.参数 线程信息, 整数型
.参数 消息产生的时间, 文本型
.参数 消息的正文, 文本型
.参数 消息类型, 整数型
.参数 对象信息, 整数型

调试输出 (消息的正文)
.子程序 交互回调函数子程序
.参数 消息类型, 整数型
.参数 线程信息, 整数型
.参数 第三个参数, 整数型
.参数 第四个参数, 整数型
.参数 对象信息, 整数型
调试输出 (消息类型)

补充:通过经过进一步测试,如果下载的网页是纯静态页面,就可以正常下载,如果是伪静态或者动态页面,就不能正常下载,都是提示无法获取文件大小,然后就停止了下载。用“HTTP读文件”倒是可以下载正常,但是这样就没法获取到下载进度等信息。

用HTTP下载的方式写的多线程的源码:

http://pan.baidu.com/s/1miBEHXe

推荐阅读相关文章:编程学习记录

本文地址:http://www.mianfeidianhua.net/chuansongzhichiku.html
版权所有 © 转载时必须以链接形式注明作者和原始出处!

本文目前尚无任何评论.

发表评论